#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<a href=\")([^"]*)-([^&"]*)(?=\.html\">)"
Local $sString = "<div id="breadcrumb-section">" & @CRLF & _
" <ol id="breadcrumbs">" & @CRLF & _
" <li class="first">" & @CRLF & _
" <span>" & @CRLF & _
" <a href="index.html">Technologies</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Some-Technologies-Documentation_218464400.html">Some Technologies Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Some-Other-Documentation_268370090.html">Some Other Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Another-Documentation_268370112.html">Another Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" </ol>" & @CRLF & _
"</div>"
Local $sSubst = "$1_$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)