using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\$.*?\$|\$.*?\\\$|(\$.*?\$)";
string input = @"escaping the syntax, e.g. The price is 5\$ to 10\$ or $ to \$ or \$ to $ or capture $ to $";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}