re = /\\\$.*?\$|\$.*?\\\$|(\$.*?\$)/m
str = 'escaping the syntax, e.g. The price is 5\\$ to 10\\$ or $ to \\$ or \\$ to $ or capture $ to $'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end