$re = '/\\\\\$.*?\$|\$.*?\\\\\$|(\$.*?\$)/m';
$str = 'escaping the syntax, e.g. The price is 5\\$ to 10\\$ or $ to \\$ or \\$ to $ or capture $ to $';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);