#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[BDFHJLNPRTVXZ02468])0(?=1$)|(?<=[ACEGIKMOQSUWY13579]0)1$"
Local $sString = "FCW2026P4F501" & @CRLF & _
"FCW2026P4F601" & @CRLF & _
"AABA01" & @CRLF & _
"AAB001"
Local $sSubst = "${1:+0:1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)