using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[BDFHJLNPRTVXZ02468])0(?=1$)|(?<=[ACEGIKMOQSUWY13579]0)1$";
string substitution = @"${1:+0:1}";
string input = @"FCW2026P4F501
FCW2026P4F601
AABA01
AAB001";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}