re = /(?<=[BDFHJLNPRTVXZ02468])0(?=1$)|(?<=[ACEGIKMOQSUWY13579]0)1$/m
str = 'FCW2026P4F501
FCW2026P4F601
AABA01
AAB001'
subst = '${1:+0:1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result