const regex = new RegExp('(?<=[BDFHJLNPRTVXZ02468])0(?=1$)|(?<=[ACEGIKMOQSUWY13579]0)1$', 'gm')
const str = `FCW2026P4F501
FCW2026P4F601
AABA01
AAB001`;
const subst = `${1:+0:1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);