package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*position: (\d*).*`)
var str = `Error while reading data, error message: Error detected while parsing row starting at position: 289830. Error: Bad character (ASCII 0) encountered.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}