$re = '/^.*position: (\d*).*/m';
$str = 'Error while reading data, error message: Error detected while parsing row starting at position: 289830. Error: Bad character (ASCII 0) encountered.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);