// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*position: (\d*).*").unwrap();
let string = "Error while reading data, error message: Error detected while parsing row starting at position: 289830. Error: Bad character (ASCII 0) encountered.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}