import re
regex = re.compile(r"^.*position: (\d*).*", flags=re.MULTILINE)
test_str = "Error while reading data, error message: Error detected while parsing row starting at position: 289830. Error: Bad character (ASCII 0) encountered."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")