using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""]+)"":";
string input = @"{ ""name"": ""J\\""ohn Smith"" }
{
""colors"": [
{
""color"": ""black"",
""category"": ""hue"",
""type"": ""primary"",
""code"": {
""rgba"": [255,255,255,1],
""hex"": ""#000""
}
},
{
""color"": ""white"",
""category"": ""value"",
""code"": {
""rgba"": [0,0,0,1],
""hex"": ""#FFF""
}
},
{
""color"": ""red"",
""category"": ""hue"",
""type"": ""primary"",
""code"": {
""rgba"": [255,0,0,1],
""hex"": ""#FF0""
}
},
{
""color"": ""blue"",
""category"": ""hue"",
""type"": ""primary"",
""code"": {
""rgba"": [0,0,255,1],
""hex"": ""#00F""
}
},
{
""color"": ""yellow"",
""category"": ""hue"",
""type"": ""primary"",
""code"": {
""rgba"": [255,255,0,1],
""hex"": ""#FF0""
}
},
{
""color"": ""green"",
""category"": ""hue"",
""type"": ""secondary"",
""code"": {
""rgba"": [0,255,0,1],
""hex"": ""#0F0""
}
},
]
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}