// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([^"]+)":"#).unwrap();
let string = "{ \"name\": \"J\\\\\"ohn Smith\" }
{
\"colors\": [
{
\"color\": \"black\",
\"category\": \"hue\",
\"type\": \"primary\",
\"code\": {
\"rgba\": [255,255,255,1],
\"hex\": \"#000\"
}
},
{
\"color\": \"white\",
\"category\": \"value\",
\"code\": {
\"rgba\": [0,0,0,1],
\"hex\": \"#FFF\"
}
},
{
\"color\": \"red\",
\"category\": \"hue\",
\"type\": \"primary\",
\"code\": {
\"rgba\": [255,0,0,1],
\"hex\": \"#FF0\"
}
},
{
\"color\": \"blue\",
\"category\": \"hue\",
\"type\": \"primary\",
\"code\": {
\"rgba\": [0,0,255,1],
\"hex\": \"#00F\"
}
},
{
\"color\": \"yellow\",
\"category\": \"hue\",
\"type\": \"primary\",
\"code\": {
\"rgba\": [255,255,0,1],
\"hex\": \"#FF0\"
}
},
{
\"color\": \"green\",
\"category\": \"hue\",
\"type\": \"secondary\",
\"code\": {
\"rgba\": [0,255,0,1],
\"hex\": \"#0F0\"
}
},
]
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}