import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]+)\":";
final String string = "{ \"name\": \"J\\\\\"ohn Smith\" }\n\n"
+ "{\n"
+ " \"colors\": [\n"
+ " {\n"
+ " \"color\": \"black\",\n"
+ " \"category\": \"hue\",\n"
+ " \"type\": \"primary\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [255,255,255,1],\n"
+ " \"hex\": \"#000\"\n"
+ " }\n"
+ " },\n"
+ " {\n"
+ " \"color\": \"white\",\n"
+ " \"category\": \"value\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [0,0,0,1],\n"
+ " \"hex\": \"#FFF\"\n"
+ " }\n"
+ " },\n"
+ " {\n"
+ " \"color\": \"red\",\n"
+ " \"category\": \"hue\",\n"
+ " \"type\": \"primary\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [255,0,0,1],\n"
+ " \"hex\": \"#FF0\"\n"
+ " }\n"
+ " },\n"
+ " {\n"
+ " \"color\": \"blue\",\n"
+ " \"category\": \"hue\",\n"
+ " \"type\": \"primary\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [0,0,255,1],\n"
+ " \"hex\": \"#00F\"\n"
+ " }\n"
+ " },\n"
+ " {\n"
+ " \"color\": \"yellow\",\n"
+ " \"category\": \"hue\",\n"
+ " \"type\": \"primary\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [255,255,0,1],\n"
+ " \"hex\": \"#FF0\"\n"
+ " }\n"
+ " },\n"
+ " {\n"
+ " \"color\": \"green\",\n"
+ " \"category\": \"hue\",\n"
+ " \"type\": \"secondary\",\n"
+ " \"code\": {\n"
+ " \"rgba\": [0,255,0,1],\n"
+ " \"hex\": \"#0F0\"\n"
+ " }\n"
+ " },\n"
+ " ]\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}