import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "index:\\s*([0-9]+)\\s*,";
final String string = "node v10.15.2 linux/amd64\n\n"
+ " [ 'b', index: 4, input: '++a+b+c++', groups: undefined ] 'hello'\n"
+ " [ 'c', index: 6, input: '++a+b+c++', groups: undefined ] 'hello'\n"
+ " Separating top and bottom so it's easier to read\n"
+ " [ 'a', index: 2, input: '++a+b+c++', groups: undefined ]\n"
+ " [ 'b', index: 4, input: '++a+b+c++', groups: undefined ]\n"
+ " [ 'c', index: 6, input: '++a+b+c++', groups: undefined ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}