import re
regex = re.compile(r"index:\s*([0-9]+)\s*,", flags=re.MULTILINE)
test_str = ("node v10.15.2 linux/amd64\n\n"
" [ 'b', index: 4, input: '++a+b+c++', groups: undefined ] 'hello'\n"
" [ 'c', index: 6, input: '++a+b+c++', groups: undefined ] 'hello'\n"
" Separating top and bottom so it's easier to read\n"
" [ 'a', index: 2, input: '++a+b+c++', groups: undefined ]\n"
" [ 'b', index: 4, input: '++a+b+c++', groups: undefined ]\n"
" [ 'c', index: 6, input: '++a+b+c++', groups: undefined ]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")