use strict;
my $str = 'node v10.15.2 linux/amd64
[ \'b\', index: 4, input: \'++a+b+c++\', groups: undefined ] \'hello\'
[ \'c\', index: 6, input: \'++a+b+c++\', groups: undefined ] \'hello\'
Separating top and bottom so it\'s easier to read
[ \'a\', index: 2, input: \'++a+b+c++\', groups: undefined ]
[ \'b\', index: 4, input: \'++a+b+c++\', groups: undefined ]
[ \'c\', index: 6, input: \'++a+b+c++\', groups: undefined ]';
my $regex = qr/index:\s*([0-9]+)\s*,/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}