re = /index:\s*([0-9]+)\s*,/m
str = 'node v10.15.2 linux/amd64
[ \'b\', index: 4, input: \'++a+b+c++\', groups: undefined ] \'hello\'
[ \'c\', index: 6, input: \'++a+b+c++\', groups: undefined ] \'hello\'
Separating top and bottom so it\'s easier to read
[ \'a\', index: 2, input: \'++a+b+c++\', groups: undefined ]
[ \'b\', index: 4, input: \'++a+b+c++\', groups: undefined ]
[ \'c\', index: 6, input: \'++a+b+c++\', groups: undefined ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end