using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([0-9a-f])\1([0-9a-f])\2([0-9a-f])\3";
string substitution = @"#$1$2$3";
string input = @"#333333
#666666
#ff6666
#d7d7d7
#e5e5e5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}