$re = '/#([0-9a-f])\1([0-9a-f])\2([0-9a-f])\3/m';
$str = '#333333
#666666
#ff6666
#d7d7d7
#e5e5e5';
$subst = "#$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;