import re
regex = re.compile(r"#([0-9a-f])\1([0-9a-f])\2([0-9a-f])\3", flags=re.MULTILINE)
test_str = ("#333333\n"
"#666666\n"
"#ff6666\n\n"
"#d7d7d7\n"
"#e5e5e5")
subst = "#$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)