const regex = /#([0-9a-f])\1([0-9a-f])\2([0-9a-f])\3/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([0-9a-f])\\1([0-9a-f])\\2([0-9a-f])\\3', 'gm')
const str = `#333333
#666666
#ff6666
#d7d7d7
#e5e5e5`;
const subst = `#$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);