const regex = /(MY_TABLE_\d+)(\s*)(CODE_TYPE.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(MY_TABLE_\\d+)(\\s*)(CODE_TYPE.*)', 'gm')
const str = `MY_TABLE_1 MY_CODE "OFF"
MY_TABLE_1 YOUR_CODE "ON"
MY_TABLE_1 CODE_TYPE "<NONE>"
MY_TABLE_1 CODE_STATE "ON"
MY_TABLE_2 MY_CODE "IGNORE"
MY_TABLE_2 YOUR_CODE "IGNORE"
MY_TABLE_2 CODE_TYPE "FLAGGED"
MY_TABLE_2 CODE_STATE "ON"`;
const subst = `\1\2\3\n\1\2USER_CODE "DEFAULT"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);