// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(MY_TABLE_\d+)(\s*)(CODE_TYPE.*)").unwrap();
let string = "MY_TABLE_1 MY_CODE \"OFF\"
MY_TABLE_1 YOUR_CODE \"ON\"
MY_TABLE_1 CODE_TYPE \"<NONE>\"
MY_TABLE_1 CODE_STATE \"ON\"
MY_TABLE_2 MY_CODE \"IGNORE\"
MY_TABLE_2 YOUR_CODE \"IGNORE\"
MY_TABLE_2 CODE_TYPE \"FLAGGED\"
MY_TABLE_2 CODE_STATE \"ON\"";
let substitution = "\\1\\2\\3\\n\\1\\2USER_CODE \"DEFAULT\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}