$re = '/(MY_TABLE_\d+)(\s*)(CODE_TYPE.*)/m';
$str = 'MY_TABLE_1 MY_CODE "OFF"
MY_TABLE_1 YOUR_CODE "ON"
MY_TABLE_1 CODE_TYPE "<NONE>"
MY_TABLE_1 CODE_STATE "ON"
MY_TABLE_2 MY_CODE "IGNORE"
MY_TABLE_2 YOUR_CODE "IGNORE"
MY_TABLE_2 CODE_TYPE "FLAGGED"
MY_TABLE_2 CODE_STATE "ON"';
$subst = "\1\2\3\n\1\2USER_CODE \"DEFAULT\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;