use strict;
my $str = 'MY_TABLE_1 MY_CODE "OFF"
MY_TABLE_1 YOUR_CODE "ON"
MY_TABLE_1 CODE_TYPE "<NONE>"
MY_TABLE_1 CODE_STATE "ON"
MY_TABLE_2 MY_CODE "IGNORE"
MY_TABLE_2 YOUR_CODE "IGNORE"
MY_TABLE_2 CODE_TYPE "FLAGGED"
MY_TABLE_2 CODE_STATE "ON"';
my $regex = qr/(MY_TABLE_\d+)(\s*)(CODE_TYPE.*)/mp;
my $subst = '\\1\\2\\3\\n\\1\\2USER_CODE "DEFAULT"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";