#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^#.*$|(\d+))"
Local $sString = "# Document ID 8934" & @CRLF & _
"# Last updated 2018-05-06" & @CRLF & _
"52 84 12 70 23 2 7 20 1 5" & @CRLF & _
"4 2 7 81 32 98 2 0 77 6" & @CRLF & _
"(..and so on..)" & @CRLF & _
"" & @CRLF & _
"t #####"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")