import re
regex = re.compile(r"(?:^#.*$|(\d+))", flags=re.MULTILINE)
test_str = ("# Document ID 8934\n"
"# Last updated 2018-05-06\n"
"52 84 12 70 23 2 7 20 1 5\n"
"4 2 7 81 32 98 2 0 77 6\n"
"(..and so on..)\n\n"
"t #####")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")