import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^#.*$|(\\d+))";
final String string = "# Document ID 8934\n"
+ "# Last updated 2018-05-06\n"
+ "52 84 12 70 23 2 7 20 1 5\n"
+ "4 2 7 81 32 98 2 0 77 6\n"
+ "(..and so on..)\n\n"
+ "t #####";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}