package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^#.*$|(\d+))`)
var str = `# Document ID 8934
# Last updated 2018-05-06
52 84 12 70 23 2 7 20 1 5
4 2 7 81 32 98 2 0 77 6
(..and so on..)
t #####`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}