#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x) # ignore les espaces et permet donc l'indentation" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<string> ".*?" )" & @CRLF & _
" (?<number> \d+ )" & @CRLF & _
" (?<value>" & @CRLF & _
" \s* (?:" & @CRLF & _
" (?&string)" & @CRLF & _
" | (?&number)" & @CRLF & _
" | (?&list)" & @CRLF & _
" ) \s*" & @CRLF & _
" )" & @CRLF & _
" (?<list> \[ (?&value) (?: , (?&value) )* \] )" & @CRLF & _
")" & @CRLF & _
"^(?&value)$"
Local $sString = "[42, "abc", ["foo", "bar"], 10]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")