const regex = /(?x) # ignore les espaces et permet donc l'indentation
(?(DEFINE)
(?<string> ".*?" )
(?<number> \d+ )
(?<value>
\s* (?:
(?&string)
| (?&number)
| (?&list)
) \s*
)
(?<list> \[ (?&value) (?: , (?&value) )* \] )
)
^(?&value)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x) # ignore les espaces et permet donc l\'indentation
(?(DEFINE)
(?<string> ".*?" )
(?<number> \\d+ )
(?<value>
\\s* (?:
(?&string)
| (?&number)
| (?&list)
) \\s*
)
(?<list> \\[ (?&value) (?: , (?&value) )* \\] )
)
^(?&value)$', 'gm')
const str = `[42, "abc", ["foo", "bar"], 10]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}