import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) # ignore les espaces et permet donc l'indentation\n"
+ "(?(DEFINE)\n"
+ " (?<string> \".*?\" )\n"
+ " (?<number> \\d+ )\n"
+ " (?<value>\n"
+ " \\s* (?:\n"
+ " (?&string)\n"
+ " | (?&number)\n"
+ " | (?&list)\n"
+ " ) \\s*\n"
+ " )\n"
+ " (?<list> \\[ (?&value) (?: , (?&value) )* \\] )\n"
+ ")\n"
+ "^(?&value)$";
final String string = "[42, \"abc\", [\"foo\", \"bar\"], 10]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}