# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x) # ignore les espaces et permet donc l'indentation\n"
r"(?(DEFINE)\n"
r" (?<string> \".*?\" )\n"
r" (?<number> \d+ )\n"
r" (?<value>\n"
r" \s* (?:\n"
r" (?&string)\n"
r" | (?&number)\n"
r" | (?&list)\n"
r" ) \s*\n"
r" )\n"
r" (?<list> \[ (?&value) (?: , (?&value) )* \] )\n"
r")\n"
r"^(?&value)$")
test_str = "[42, \"abc\", [\"foo\", \"bar\"], 10]"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.