using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]";
string input = @"This operation bla bla bla...
// Closing marks
Confirm this command? [YES,no]
Confirm this command? (YES,no)
Confirm this command? <YES,no>
// YES,NO
Confirm this command? [YES,no]
Confirm this command? [yes,NO]
Confirm this command? [yes,no]
// YES/NO
Confirm this command? [YES/no]
Confirm this command? [yes/NO]
Confirm this command? [yes/no]
// NO,YES
Confirm this command? [no,YES]
Confirm this command? [NO,yes]
Confirm this command? [no,yes]
// NO/YES
Confirm this command? [no/YES]
Confirm this command? [NO/yes]
Confirm this command? [no/yes]
// DO NOT MATCH
Confirm this command? [YES,no,cancel]
Confirm this command? [yes,NO,cancel]
Confirm this command? [yes,no,CANCEL]
Confirm this command? [YES/no/cancel]
Confirm this command? [yes/NO/cancel]
Confirm this command? [yes/no/CANCEL]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}