# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]"
test_str = ("This operation bla bla bla...\n\n"
"// Closing marks\n"
"Confirm this command? [YES,no]\n"
"Confirm this command? (YES,no)\n"
"Confirm this command? <YES,no>\n\n"
"// YES,NO\n"
"Confirm this command? [YES,no]\n"
"Confirm this command? [yes,NO]\n"
"Confirm this command? [yes,no]\n"
"// YES/NO\n"
"Confirm this command? [YES/no]\n"
"Confirm this command? [yes/NO]\n"
"Confirm this command? [yes/no]\n\n"
"// NO,YES\n"
"Confirm this command? [no,YES]\n"
"Confirm this command? [NO,yes]\n"
"Confirm this command? [no,yes]\n"
"// NO/YES\n"
"Confirm this command? [no/YES]\n"
"Confirm this command? [NO/yes]\n"
"Confirm this command? [no/yes]\n\n\n"
"// DO NOT MATCH\n"
"Confirm this command? [YES,no,cancel]\n"
"Confirm this command? [yes,NO,cancel]\n"
"Confirm this command? [yes,no,CANCEL]\n\n"
"Confirm this command? [YES/no/cancel]\n"
"Confirm this command? [yes/NO/cancel]\n"
"Confirm this command? [yes/no/CANCEL]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.