// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]").unwrap();
let string = "This operation bla bla bla...
// Closing marks
Confirm this command? [YES,no]
Confirm this command? (YES,no)
Confirm this command? <YES,no>
// YES,NO
Confirm this command? [YES,no]
Confirm this command? [yes,NO]
Confirm this command? [yes,no]
// YES/NO
Confirm this command? [YES/no]
Confirm this command? [yes/NO]
Confirm this command? [yes/no]
// NO,YES
Confirm this command? [no,YES]
Confirm this command? [NO,yes]
Confirm this command? [no,yes]
// NO/YES
Confirm this command? [no/YES]
Confirm this command? [NO/yes]
Confirm this command? [no/yes]
// DO NOT MATCH
Confirm this command? [YES,no,cancel]
Confirm this command? [yes,NO,cancel]
Confirm this command? [yes,no,CANCEL]
Confirm this command? [YES/no/cancel]
Confirm this command? [yes/NO/cancel]
Confirm this command? [yes/no/CANCEL]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}