const regex = /\[[^][]*](*SKIP)(*FAIL)|-/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^][]*](*SKIP)(*FAIL)|-', 'g')
const str = `abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}