use strict;
my $str = 'abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days';
my $regex = qr/\[[^][]*](*SKIP)(*FAIL)|-/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}