$re = '/\[[^][]*](*SKIP)(*FAIL)|-/';
$str = 'abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);