using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<\s*(\/\s*)?([a-zA-Z0-9-:]+)([^>]*)>?$";
string input = @"<input src>
<esi:include src>
<p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}