re = /^<\s*(\/\s*)?([a-zA-Z0-9-:]+)([^>]*)>?$/m
str = '<input src>
<esi:include src>
<p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end