$re = '/^<\s*(\/\s*)?([a-zA-Z0-9-:]+)([^>]*)>?$/m';
$str = '<input src>
<esi:include src>
<p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);