package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<\s*(\/\s*)?([a-zA-Z0-9-:]+)([^>]*)>?$`)
var str = `<input src>
<esi:include src>
<p>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}