using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<!--\n(.*(?:\n.*)*?)\n?^-->";
string input = @"<!--
Title: Foo
-->
# This is a test
<!--
Title: Bar
-->
<!--
-->";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}