package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<!--\n(.*(?:\n.*)*?)\n?^-->`)
var str = `<!--
Title: Foo
-->
# This is a test
<!--
Title: Bar
-->
<!--
-->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}