re = /^<!--\n(.*(?:\n.*)*?)\n?^-->/m
str = '<!--
Title: Foo
-->
# This is a test
<!--
Title: Bar
-->
<!--
-->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end