$re = '/^<!--\n(.*(?:\n.*)*?)\n?^-->/m';
$str = '<!--
Title: Foo
-->
# This is a test
<!--
Title: Bar
-->
<!--
-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);