#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)(?:www\.)?([^\/\s]+)$|^(?:https?:\/\/)(?:www\.)?([^\/\s]+)(?:.*)$"
Local $sString = "https://domain.com" & @CRLF & _
"https://subdomain.domain.com" & @CRLF & _
"https://www.sub.sub.subdomain.domain.com" & @CRLF & _
"http://sub.masterdomain.com.au" & @CRLF & _
"https://four.submains.new.domain.luxury.co.uk" & @CRLF & _
"https://www.globo.us/games/tap-zap-boom/" & @CRLF & _
"https://www.test.com/games/socce/index.html" & @CRLF & _
"https://google.com.br/services/index.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")